Ver todos los Artículos sobre Cómo Hacer

Cómo Convertir la Fecha en Mes y Año en Excel y Google Sheets

Este tutorial muestra cómo convertir fechas a mes y año en Excel y Google Sheets.

Formatos Personalizados de Fechas en Excel

 

Formato de Números – Mostrar Sólo el Mes y el Año

Puede mostrar una fecha en la pantalla como sólo el mes y el año utilizando el formato numérico personalizado en Excel.

  1. Resalte las celdas a las que desea dar formato.

Seleccionar Rango

  1. En la cinta de opciones, seleccione Inicio > Número y, a continuación, haga clic en la flecha hacia abajo del cuadro desplegable Formato de número.

Opciones Desplegables Formato de Número

  1. Selecciona Más formatos de número…

Más Formatos de Número

O

Seleccione la pequeña flecha en la esquina inferior derecha del grupo Número para abrir el cuadro de diálogo de formato de número.

Menú Formato de Número

  1. A continuación, selecciona Personalizado en la parte inferior de la lista. En el cuadro Tipo, introduzca mmmm aaaa. Por último, haz clic en Aceptar para aplicar el formato a las celdas.

Formato Personalizado de Celdas

El valor de la celda sigue siendo el mismo, pero el número se muestra como noviembre 2020 en lugar de 3/11/2020.

Formato Personalizado de Fechas en Excel

Pruebe mmm aaaa y mm aa para crear más formatos de números personalizados.

Formatos Personalizados de Fechas en Excel

 

Función TEXTO

También puede utilizar la función TEXTO para extraer el mes y el año de una fecha.

Función Texto para Formatear Fechas en Excel

 

  1. Haz clic en la celda C3
  2. Escribe la siguiente fórmula
=TEXTO(B3;"mm")

Resultado Función Texto para Formatear Fechas en Excel

  1. Haz clic en la celda D3.
  2. Escribe la siguiente fórmula.
=TEXTO(B3;"yyyy")

Función Texto para Extraer Año en Excel

 

La fórmula TEXTO devuelve los valores a Excel como texto alineado a la izquierda.

Al igual que en el caso del formato numérico personalizado, puedes utilizar diversas variaciones de mm y aaaacomo mmm, mmmm, yy- para devolver el mes y el año en diferentes formatos.

Funciones de MES y AÑO

Para extraer el mes y el año de una fecha, puede utilizar las funciones MES y AÑO.

Función Año en Excel

  1. Haz clic en la celda C3.
  2. Escribe la siguiente fórmula.
= MES(B3)

Función Mes en Excel

La celda muestra entonces sólo el mes correspondiente.

Función Mes en Excel

 

  1. Haz clic en la celda D3.
  2. Escribe la siguiente fórmula.
=AÑO(B3)

Función Año en Excel

 

La celda muestra el año correspondiente.

Las funciones MES y AÑO devuelven los datos a los números alineados a la derecha de Excel.

Formato de Números en Google Sheets

También puedes utilizar el formato numérico personalizado en Google Sheets para mostrar una fecha como mmmm aaaa.

  1. Resalte las celdas a las que desea dar formato.
  2. Haz clic en la lista desplegable 123 de la barra de herramientas de Google Sheets.
  3. Selecciona Fecha y hora personalizadas.

Formato Personalizado de Fechas en Google Sheets Paso1

 

El formato que tiene actualmente se muestra en el cuadro de formato. Puede añadir y eliminar formatos según sea necesario, o seleccionar un formato adecuado.

Cuadro Diálogo Formatos de fecha y hora personalizados

 

  1. Haz clic en las flechitas a la derecha del cuadro Mes para seleccionar el formato de mes que necesitas.

Cuadro Diálogo Formatos de fecha y hora personalizados Elegir Formato

 

  1. Elimina el formato Día del cuadro de formato personalizado.

Eliminar Día en Formato Personalizado

  1. Haz clic en las flechitas a la derecha del cuadro Año para seleccionar el formato correcto para el año.

Elegir Formato Año

 

  1. Elimina los separadores adicionales entre el mes y el año y asegúrate de que haya un espacio entre los formatos de mes y año.

Eliminar Separadores

 

  1. Haz clic en Aplicar para aplicar el formato a tu hoja de cálculo.

Aplicar Formato en Google Sheets

Las celdas seleccionadas tienen ahora el formato correspondiente.

Formato de Fecha Personalizado Aplicado en Google Sheets

Pruebe mmm aaaa y mm aaaa para crear más formatos de números personalizados.

Formatos de Fecha Personalizados en Google Sheets

 

Funciones de Mes y Año en Google Sheets

Para extraer el mes y el año de una fecha, puede utilizar las funciones MES y AÑO.

Funciones de Mes y Año en Google Sheets

  1. Haz clic en la celda C3.
  2. Escribe la siguiente fórmula.
= MES(B3)

Función Mes en Google Sheets

La celda sólo muestra el mes correspondiente.

Función Mes en Google Sheets

  1. Haz clic en la celda D3.
  2. Escribe la siguiente fórmula.
=AÑO(B3)

Función Año en Google Sheets

La celda muestra el año correspondiente.

Función Año en Google Sheets

Ver todos los Artículos sobre Cómo Hacer